phpstudy切换php版本

程序
0 528
caixiaoxu
2018-12-08

phpstudy在切换php版本的时候,如果本身自带有几个不同的php版本,但因为需求,可能需要更高的版本,这里演示一下php7.2版本


首先到http://windows.php.net/download/下载自己要切换的PHP新版本(暂时不建议用php7.3,因为还在测试中,日期2018.12.08)

看准了自己要的版本,nts和ts的选择,位数


下载下来后解压,重命名,放到phpstudy的php目录下


这时候重启phpstudy,就可以在切换版本的那个地方看到你刚下载的php版本选项,选中即可切换成功。

题外:

在使用composer的时候,会发现它识别的php版本依旧是原来的版本,那是因为path没改的原因。

打开系统属性--高级--环境变量


双击编辑下方的path


PHP版本,如果没有就新建一个,如果原先有设置过的,就改到指向新的php版本


重启cmd或者phpstrom,然后运行composer install 就可以了

回帖